EasySSO 4.2.9 IP Filter issues with IPv6 - "an IPv6 address should contain 8 shorts"
Incident Report for TechTime Initiative Group
Resolved
We consider this one resolved
Posted Dec 06, 2019 - 10:21 NZDT
Update
We are continuing to monitor for any further issues.
Posted Nov 23, 2019 - 17:47 NZDT
Identified
We have identified that IP Filtering functionality is currently failing to parse IPv6 addresses due to a change introduced several years ago. 4.2.9 exposed this since in HTTP Headers authenticator we don't look at proxied client IP address, only at the proxy's address itself, and that was being passed as IPv6 address.
Posted Nov 06, 2019 - 21:15 NZDT
Investigating
Customers report that with version 4.2.9 in HTTP header authenticator the IP Filter is failing with message "an IPv6 address should contain 8 shorts" in a situation where previous versions work fine.
Posted Oct 22, 2019 - 23:15 NZDT
This incident affected: TechTime Data Center Apps (EasySSO for Bitbucket Data Center, EasySSO for Jira Data Center, EasySSO for Confluence Data Center) and TechTime Server Apps (EasySSO for Jira Server, EasySSO for Confluence Server, EasySSO for Bitbucket Server).