Degraded Performance of Cloud Apps

Incident Report for TechTime Initiative Group

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 14:55 NZDT

Monitoring

A fix has been deployed and the issue appears to be resolved. We will continue to monitor the issue.
Posted Nov 03, 2025 - 13:31 NZDT

Identified

We have mitigated the immediate issue, and are in the process of deploying a fixed version.
Posted Nov 03, 2025 - 13:06 NZDT

Investigating

We have become aware of abnormally high CPU usage in our database hosting, causing degraded performance.

We have traced the issue and are preparing an emergency fix.

Some downtime while the fix is deployed is possible
Posted Nov 03, 2025 - 12:00 NZDT
This incident affected: TechTime Cloud Apps (Embed Google Maps Pro in Atlassian Cloud, EasyTime for Jira Cloud, Time Tracking for Confluence Cloud, EasySync for Jira, Risk Register Dashboard, Jira Service Management Knowledge Analysis, EasyTime for Confluence Cloud, User Management for Jira Cloud, User Management for Confluence Cloud).