User Management Jira & Confluence Cloud outage after platform update

Incident Report for TechTime Initiative Group

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 14:55 NZDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 04, 2025 - 15:09 NZDT

Investigating

We are currently investigating an issue with User Management Jira and Confluence Cloud after updating our cloud platform.
Posted Nov 04, 2025 - 12:11 NZDT
This incident affected: TechTime Cloud Apps (User Management for Jira Cloud, User Management for Confluence Cloud).