User Management Jira & Confluence Scheduled Actions pages are broken

Incident Report for TechTime Initiative Group

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2026 - 17:56 NZST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 10, 2026 - 13:02 NZST

Investigating

We are experiencing an issue with the Scheduled Actions Overview and Editing pages. Filters involving product access are not populating correctly. And the Overview page is not displaying the entire configuration.
We are currently investigating the problem.
Posted Jun 10, 2026 - 11:08 NZST
This incident affects: TechTime Cloud Apps (User Management for Jira Cloud, User Management for Confluence Cloud).