EasyTime tracking issues have been resolved by Atlassian, we are monitoring for any further issues.
Posted Dec 16, 2025 - 10:16 NZDT
Monitoring
We have resolve all of the critical issues and all apps are now operational.
We have identified an EasyTime error which is stopping tracking of viewing issues, which appears to be caused by an issue with Atlassian's API. We have reported this to them and will continue to monitor.
Posted Dec 15, 2025 - 21:01 NZDT
Update
We are continuing to work through remaining fixes. Google Maps is now operational
Posted Dec 15, 2025 - 18:29 NZDT
Update
We have restored some services including User Management. EasyTime is not automatically tracking time from Jira, we are working urgently to resolve the issue.
Posted Dec 15, 2025 - 17:16 NZDT
Update
We are testing a fix for the issue and plan to deploy it shortly.
Posted Dec 15, 2025 - 11:28 NZDT
Identified
We have identified the issue and are working on an urgent fix to resolve the issue. Expect an update within 1hr.
Posted Dec 15, 2025 - 10:31 NZDT
Update
We are continuing to investigate this issue.
Posted Dec 15, 2025 - 09:58 NZDT
Investigating
We are investigating an issue where our Cloud Apps are not reachable.
Posted Dec 15, 2025 - 09:55 NZDT
This incident affected: TechTime Cloud Apps (Embed Google Maps Pro in Atlassian Cloud, EasyTime for Jira Cloud, Time Tracking for Confluence Cloud, EasySync for Jira, Risk Register Dashboard, Jira Service Management Knowledge Analysis, EasyTime for Confluence Cloud, User Management for Jira Cloud, User Management for Confluence Cloud).