Confirm Selection for Bulk User Action doesn't work for large number of user records
Incident Report for TechTime Initiative Group
Update
We are continuing to monitor for any further issues.
Posted Jan 24, 2020 - 14:40 NZDT
Monitoring
A fix has been implemented and the new code is being tested
Posted Dec 18, 2019 - 12:30 NZDT
Identified
An issue in the code has been identified where the application attempts to store too much data unnecessarily in the browser local storage and fails. We will reduce the amount of data we store and also introduce measures to only ever take 50% of the available storage for this operations and inform the user
Posted Dec 16, 2019 - 11:15 NZDT
Investigating
For a while, from time to time we have had reports from customers that "Confirm Selection" fails in Bulk User Actions on a large number of user records (~20k-30k).

Selecting fewer users continues to work
Posted Dec 07, 2019 - 00:15 NZDT
This incident affected: TechTime Data Center Apps (UserManagement for Jira Data Center, UserManagement for Confluence Data Center, UserManagement for Bitbucket Data Center) and TechTime Server Apps (UserManagement for Jira Server, UserManagement for Confluence Server, UserManagement for Bitbucket Server).