After upgrade to Confluence 7.3 and/or Java 11, EasySSO stops working
Incident Report for TechTime Initiative Group
Update
A fix has been produced by including unaltered com.sun.jndi.dns classes from AdoptOpenJDK under GPLv2+CE license. Source code from jdk8u242-b07 has been included.
Posted Apr 08, 2020 - 07:45 NZST
Update
A workaround has been identified - JVM needs two extra parameters to be added:
--add-exports=jdk.naming.dns/com.sun.jndi.dns=java.naming -Datlassian.org.osgi.framework.bootdelegation.extra=com.sun.*

An article has been added to our FAQ and Get Started page: https://techtime.co.nz/display/TECHTIME/Additional+Configuration+for+Java+11
Posted Mar 03, 2020 - 19:45 NZDT
Identified
Confluence 7.3 includes a bundled AdoptOpenJDK 11, which has moved DNS-related com.sun packages to a module not exported by default, thus making it not available to EasySSO and IOPLEX Jespa code.

This would affect any of EasySSO apps, when running on JDK 11, but only Confluence it seems includes it by default.
Posted Feb 26, 2020 - 11:15 NZDT
Investigating
We have had a report that after upgrade of Confluence to version 7.3 EasySSO has stopped working.
Posted Feb 24, 2020 - 20:15 NZDT
This incident affected: TechTime Data Center Apps (EasySSO for Bitbucket Data Center, EasySSO for Jira Data Center, EasySSO for Confluence Data Center) and TechTime Server Apps (EasySSO for Jira Server, EasySSO for Confluence Server, EasySSO for Bitbucket Server, EasySSO for Bamboo Server).