EasySSO 4.2.10 fix for fail page is incomplete
Incident Report for TechTime Initiative Group
Resolved
Customer who reported the problem has confirmed that it is resolved.
Posted Oct 26, 2019 - 14:18 NZDT
Identified
The intended fix in 4.2.10 contained two parts and the 2nd part was not released: if we do arrive to the fail page while logged in we will immediately redirect to the the application root/dashboard.

We are preparing version 4.2.11 with this 2nd part of the fix included
Posted Oct 23, 2019 - 22:00 NZDT
Investigating
Customers reported that version 4.2.10 does not fix the problem with SAML fail page in full.

The original problem reported against 4.2.8 has not been fixed:

When SAML login is explicitly cancelled on the IdP side, the response to EasySSO is correctly identified as a "failure to login", the fail page is displayed (still anonymously at this time), then the user clicks on the default "Log In" link in the application and logs in via regular login screen, but is then redirected to the page they clicked from - the "fail page".
Posted Oct 23, 2019 - 20:30 NZDT
This incident affected: TechTime Data Center Apps (EasySSO for Bitbucket Data Center, EasySSO for Jira Data Center, EasySSO for Confluence Data Center) and TechTime Server Apps (EasySSO for Jira Server, EasySSO for Confluence Server, EasySSO for Bitbucket Server).