TechTime Support Portal Availability

Incident Report for TechTime Initiative Group

Resolved

Functionality is back to normal.
Posted Dec 15, 2025 - 12:44 NZDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 15, 2025 - 09:56 NZDT

Investigating

We are currently investigating an issue causing our support portal to be unreachable.
You can still create tickets with us via email to support@techtime.co.nz
Posted Dec 15, 2025 - 09:30 NZDT
This incident affected: TechTime Service Desk.