EasySSO doesn't perform automatic NLTM/Kerberos re-login from Jira Software boards when the session expires
Incident Report for TechTime Initiative Group
Resolved
Posted Jan 27, 2020 - 15:14 NZDT
Update
We are continuing to monitor for any further issues.
Posted Jan 27, 2020 - 15:04 NZDT
Monitoring
A hotfix has been delivered to the customer who reported the issue.
Posted Dec 19, 2019 - 16:45 NZDT
Identified
We have identified a fix - JSW board sends a REST request (that is normally ignored by EasySSO) to identify if the session is alive and then a redirect is issued to the login page (that is also ignored by EasySSO). We will intercept this REST request and perform NTLM/Kerberos authentication on this REST request only as an exception.
Posted Dec 16, 2019 - 22:00 NZDT
Investigating
Customers inform that with NTLM, after a successful SSO, when the browser window is left for a long time open on the JSW board, when the user next accesses the board they get redirected to the default login screen.
Posted Nov 28, 2019 - 10:45 NZDT
This incident affected: TechTime Data Center Apps (EasySSO for Bitbucket Data Center, EasySSO for Jira Data Center, EasySSO for Confluence Data Center) and TechTime Server Apps (EasySSO for Jira Server, EasySSO for Confluence Server, EasySSO for Bitbucket Server, EasySSO for Bamboo Server, EasySSO for Fisheye/Crucible Server).