EasySSO Jira disabled on Jira v8.22.2
Incident Report for TechTime Initiative Group
Resolved
This incident has now been resolved. Update have been applied and monitoring has been stable.
Posted Apr 27, 2022 - 09:52 NZST
Monitoring
A bugfix has been created and a new version for EasySSO Jira is available. The new version (v4.5.11.3) is compatible with Jira 8.22.2 and can be downloaded from https://marketplace.atlassian.com/apps/1212581/easy-sso-jira-kerberos-ntlm-saml/version-history
Posted Apr 22, 2022 - 16:41 NZST
Identified
The incompatibility with Jira v8.22.2 comes from a package (org.apache.xml.security) no longer being provided by the underlying Jira application. We are now working to implement a fix
Posted Apr 22, 2022 - 10:54 NZST
Update
Easy SSO Jira is still working correctly for versions earlier than 8.22.2.
Posted Apr 22, 2022 - 09:28 NZST
Investigating
We are currently investigating the issue
Posted Apr 22, 2022 - 09:08 NZST
This incident affected: TechTime Server Apps (EasySSO for Jira Server) and TechTime Data Center Apps (EasySSO for Jira Data Center).