GoogleMaps Embedding macro 6.0.3 on Server/DC conflicts with Confluence 7.13.1 file preview functionality
Incident Report for TechTime Initiative Group
Resolved
Posted Nov 05, 2021 - 14:51 NZDT
Identified
The issue has been traced to some Javascript tests helper code being included in the production resource files that caused conflicts with Confluence built-in functionality. A new build of TechTime Google Maps Embed Macro app 6.0.4 is being prepared to fix this issue.
Posted Nov 05, 2021 - 13:02 NZDT
Update
The problem seems to be caused by the new functionality introduced in version 6.x – auto-convert of copy/pasted Google Maps links into embedded Google Maps: https://techtime.co.nz/display/TECHTIME/Save+some+brain+power+-+Google+Maps+for+Confluence+is+now+easier

For an immediate fix/workaround this particular functionality can be disabled in UPM:
- find TechTime Google Maps Embedding Macro app record, open that up
- locate a list of modules (should say 9 out of 9 enabled), open that up
- locate the module "Autoconvert google maps urls" and disable that one.

This will stop auto-convert copy/paste functionality, but the map functionality for the already existing maps and ability to insert new ones by explicitly inserting the macro – will continue to work.
Posted Nov 05, 2021 - 10:57 NZDT
Investigating
We've been alerted that GoogleMaps Embedding macro version 6.0.3 on Server/Data Center seems to cause Confluence 7.13.1 file preview functionality to stop working
Posted Nov 04, 2021 - 03:45 NZDT
This incident affected: TechTime Data Center Apps (GoogleMaps Embed macro for Confluence Data Center) and TechTime Server Apps (GoogleMaps Embed macro for Confluence Server).