EasySSO for Jira 4.4.5 with SAML not logging in a new user with default groups on the first attempt
Incident Report for TechTime Initiative Group
Resolved
Posted Dec 23, 2020 - 14:34 NZDT
Identified
We have traced the issue to Jira-specific API differences and (some rather dodgy) request-level caching of user's group membership. This has been triggered by group-related changes in EasySSO 4.4.x
We have introduced code to clear the cache after user is added to groups by EasySSO.
Posted Dec 23, 2020 - 09:00 NZDT
Investigating
We have had a report that SAML in EasySSO for Jira when configured to create a user on successful login and add default groups does not produce a successful login on the first attempt. The user is created and is added to the default groups but is unable to login. A subsequent login is successful.
Posted Dec 22, 2020 - 19:30 NZDT
This incident affected: TechTime Server Apps (EasySSO for Jira Server) and TechTime Data Center Apps (EasySSO for Bitbucket Data Center).